Author Topic: Bugs observed in Linux  (Read 5806 times)

0 Members and 1 Guest are viewing this topic.

Offline Erik Luken

  • Administrator
  • Admiral of the Fleet
  • *****
  • Posts: 5111
  • Thanked: 103 times
    • Arkayn Game Design
Re: Bugs observed in Linux
« Reply #15 on: September 06, 2011, 08:22:48 AM »
I found a game ending bug on Linux on wine with the version posted by Catty. 

Around the date (when starting with year 2025) of 2027 Sept.  29 I get:
This is followed by a seemingly endless stream of
After restarting I start again from just before the error and from there it just occurs again after advancing time.

I've got no idea how to fix this.   My wine is telling me the following up to this point:The package sources at WineHQ (I am using Ubuntu 11.  04) only seem to provide wine-1.  3.  15,, that's why I haven't got 1.  3.  16 yet. 
Change your decimal separator to a period instead of comma.
 

Offline Antsan

  • Leading Rate
  • *
  • A
  • Posts: 12
Re: Bugs observed in Linux
« Reply #16 on: September 11, 2011, 03:14:33 PM »
That doesn't help.  In my user. reg there even is a line that says
Quote
"sDecimal"=". "

I changed the settings of my System, too.
 

Offline Antsan

  • Leading Rate
  • *
  • A
  • Posts: 12
Re: Bugs observed in Linux
« Reply #17 on: September 13, 2011, 10:50:08 AM »
Got it fixed:

There's three different parts regarding system language in Ubuntu-Wine:
First there's Wine's preferences.
Second there is something like "regional formats" (translated from german, mustn't be accurate) which is for time, numbers and such stuff.

Both of those above where set to English standards.

Then there's the settings for the language of menus and windows.  As this shouldn't affect number formats I didn't change it.
Well, now I tried changing that too and it worked.  I have no idea why.
 

Offline DizzyFoxkit

  • Petty Officer
  • **
  • Posts: 29
Re: Bugs observed in Linux
« Reply #18 on: December 01, 2011, 12:21:14 AM »
Every time my Naval Officers shuffle around I get a 424 429 error that doesn't go away, I can get rid of it by closing and opening the program again.    Any Ideas as to why this happens linux people? The only modifications I've made for Aurora are oleut32 and ole32 along with dcom32
Wine ver: 1.   3.   3
Linux Flavor/Ver: Ubuntu 10.   10
(also, If I'm necroposting please tell me.   .   .    )
« Last Edit: December 01, 2011, 05:15:32 PM by DizzyFoxkit »
 

Offline Catty Nebulart

  • Petty Officer
  • **
  • C
  • Posts: 21
Re: Bugs observed in Linux
« Reply #19 on: December 02, 2011, 06:52:04 PM »
No idea why but I know the issue is fixable. I think it has something to do with the IE components. try using winetricks to install IE6 or fake IE6.

When I have time again I will probably repost a fixed wine prefix that can be used to run Aurora. and I will spend some more time hunting down these bugs and seeing what can be done about them.
 

Offline SpecialK

  • Petty Officer
  • **
  • S
  • Posts: 16
Re: Bugs observed in Linux
« Reply #20 on: December 29, 2011, 07:29:17 PM »
Still running into the ActiveX bug in WineSkin for OSX.  I'll try installing the IE components and doing some other workarounds later. . .
 

Offline SpecialK

  • Petty Officer
  • **
  • S
  • Posts: 16
Re: Bugs observed in Linux
« Reply #21 on: December 29, 2011, 09:59:14 PM »
Installing IE8 didn't work. 
 

Offline LoSboccacc

  • Sub-Lieutenant
  • ******
  • L
  • Posts: 111
  • Thanked: 1 times
Re: Bugs observed in Linux
« Reply #22 on: August 08, 2012, 01:50:51 AM »
Up! I'm on os x with wine 1.4.1

I followed most hint here but with 5.60 I have a new issue: economics window doesn't open (and no errors/log are shown)

Anyone had this issue?
 

Offline Erik Luken

  • Administrator
  • Admiral of the Fleet
  • *****
  • Posts: 5111
  • Thanked: 103 times
    • Arkayn Game Design
Re: Bugs observed in Linux
« Reply #23 on: August 08, 2012, 03:18:52 AM »
Up! I'm on os x with wine 1.4.1

I followed most hint here but with 5.60 I have a new issue: economics window doesn't open (and no errors/log are shown)

Anyone had this issue?

Try to reset windows positions from the menu option in Aurora.
 

Offline LoSboccacc

  • Sub-Lieutenant
  • ******
  • L
  • Posts: 111
  • Thanked: 1 times
Re: Bugs observed in Linux
« Reply #24 on: August 08, 2012, 04:38:22 AM »
Thad did it, thanks.
 

Offline nafaho7

  • Chief Petty Officer
  • ***
  • n
  • Posts: 34
Re: Bugs observed in Linux
« Reply #25 on: October 26, 2012, 03:13:31 PM »
To consolidate the instructions for running Aurora under Wine, allow me to present the following.
I am running Wine 1.5.10, on Ubuntu 10.04

Assuming that you have compiled Wine and installed its dependencies, you should now perform the following steps, IN ORDER.
  • Create a fresh wineprefix.  I prefer to do this by removing the existing prefix in some fashion, such as renaming it, and then entering the commands "wineserver -k" and then "wineboot".
  • After generating a fresh wineprefix, use winetricks to install the following package: "vb6run"
  • Now, you must force Wine to acknowledge the existence of several dlls.  Specifically, you need to register "ole32.dll" and "oleaut32.dll", which are already present in your wineprefix by default.  My preferred method for doing this is to use the following commands: "regsvr32 ole32.dll" and "regsvr32 oleaut32.dll"
  • Install the program commonly known to Aurora users as the "Simple Shutdown Timer" in this wineprefix.
  • Using WINECFG, set overrides for the dlls "ole32.dll" and "oleaut32.dll" to "Native, then Builtin"
  • Install Aurora as per the standard instructions.
  • Run Aurora by running the file Aurora.exe
  • Rule the Galaxy!

On my machine, at least, this allows me to run Aurora without any problems.  So far, that is.
 

Offline Catty Nebulart

  • Petty Officer
  • **
  • C
  • Posts: 21
Re: Bugs observed in Linux
« Reply #26 on: November 17, 2012, 08:27:06 AM »
Creating a new wine prefix is best done by setting the WINEPREFIX environment variable to whatever path you want and then run winecfg to generate the new prefix. However each time you then use aurora the WINEPREFIX has to be set to the same value.

Thanks for that guide, I hope it helps some people.
 

Offline TheDOC

  • Registered
  • Sub-Lieutenant
  • ******
  • T
  • Posts: 108
  • Thanked: 5 times
Re: Bugs observed in Linux
« Reply #27 on: November 26, 2012, 08:47:54 AM »
Sorry, useless post.
 

Offline Catty Nebulart

  • Petty Officer
  • **
  • C
  • Posts: 21
Re: Bugs observed in Linux
« Reply #28 on: November 26, 2012, 05:47:30 PM »
Using version 6.21 I encountered the following (precursors, swarm and invaders are enabled) Does this also happen in windows?

Error in WormholeMoves
Error 3265 was generated by DAO.Fields
Item not found in this collection
 

Offline nafaho7

  • Chief Petty Officer
  • ***
  • n
  • Posts: 34
Re: Bugs observed in Linux
« Reply #29 on: December 19, 2012, 12:18:57 PM »
Still playing version 6.10.  When using WINE version 1.5.10, and when using WINE version 1.5.19, two issues of minor impact have shown up.
  • After just over an entire game year passes, the game crashes to desktop.  No data appears to be lost, and simply running the program again seems to work fine.  I have no idea as to why this crash occurs.
  • When shutting down the program, the command prompt I used to start the program takes some length of time to finish returning to a ready command prompt.  Generally, this takes somewhere around a minute, on my machine.  Forcibly killing the process, or the wineserver, seems to have no ill effect.  Additionally, simply letting the program shut down at its own pace has no ill effect that I have noticed.
 

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52