Author Topic: v7.10 Patch  (Read 57920 times)

0 Members and 1 Guest are viewing this topic.

Offline Steve Walmsley

  • Aurora Designer
  • Admiral of the Fleet
  • Posts: 6402
  • Thanked: 653 times
    • View Profile
    • http://www.starfireassistant.com
v7.10 Patch
« on: December 27, 2015, 05:01:17 PM »
This is primarily a bug-fix patch for 7.00, although there are some new features as well. It should be fairly stable (famous last words!) but as usual give it a few days before starting any major campaigns. I suspect the independence option may be a source of some bugs, given all the possible ramifications involved, so backup before using it.

Important! This is a database patch so if you upgrade you will lose your saved game. Don't upgrade if you want to keep playing the same campaign.

This patch can only be applied to version 4.2 or later. To apply the patch, unzip the patch file and copy the files as follow:

1) Stevefire.mdb and Aurora.exe into the installation directory, overwriting the existing files with the same names
2) a11.jpg, b20.jpg and M24.jpg into the Planetjpeg sub-directory (if you don't already have them)
3) flag0390.jpg and flag0391.jpg into the Flags sub-directory (if you don't already have them)
4) race350.bmp into the Races sub-directory (if you don't already have it)

Aurora710.zip (9Mb)

Patch notes are at: http://aurora2.pentarch.org/index.php?topic=8130.0

This database in this patch contains a brand new game. No technology or ships have been created. To start a new game, delete this one. My current game is so large now that it is not really suitable for the download.

Steve
« Last Edit: January 08, 2016, 09:40:52 AM by Erik Luken »
 
The following users thanked this post: SgtVennamo, MarcAFK, Tor Cha, Griswel

Offline Mor

  • Commander
  • *********
  • Posts: 305
  • Thanked: 10 times
    • View Profile
Re: v7.10 Patch
« Reply #1 on: December 31, 2015, 08:57:33 AM »
Updated the download and install page on the wiki.

If you spot any mistakes, omissions, or can simplify\expand anything, either point it out or just click the edit button and DYI ;)
 
The following users thanked this post: Griswel

zokrr

  • Guest
Re: v7.10 Patch
« Reply #2 on: December 31, 2015, 03:23:00 PM »
I have a question, why don't you maintain the file structure for the patch, so that people can just extract the patch into the their aurora and be done with it instead of needing to open every single folder to copy the files into them?
 

Offline Garfunkel

  • Commodore
  • **********
  • Posts: 682
  • Thanked: 21 times
    • View Profile
Re: v7.10 Patch
« Reply #3 on: December 31, 2015, 07:37:41 PM »
I have a question, why don't you maintain the file structure for the patch, so that people can just extract the patch into the their aurora and be done with it instead of needing to open every single folder to copy the files into them?
But you don't need to do that? If you've already installed a patch before, you only need the .exe and the .db files.Or am I misunderstanding you?
 

zokrr

  • Guest
Re: v7.10 Patch
« Reply #4 on: December 31, 2015, 07:48:19 PM »
Quote from: Garfunkel link=topic=8143. msg84168#msg84168 date=1451612261
But you don't need to do that? If you've already installed a patch before, you only need the . exe and the . db files. Or am I misunderstanding you?
Okay, so some clarification, this my first time ever downloading this game and patch for  it, so i did not know that these files were included already in multiple patches before, i just assumed that any content included in a patch is part of the patch itself and not content from some older patch.  Which then brings me to a different point why is the full install version offered version 5. 54 and not a version already containing this older content, which apparently has been offered as part of a patch for multiple versions.  And still besides that who would it hurt if the file architecture would be maintained for patches?
 

Offline Erik Luken

  • Administrator
  • Admiral of the Fleet
  • *****
  • Posts: 5002
  • Thanked: 78 times
    • View Profile
    • Arkayn Game Design
Re: v7.10 Patch
« Reply #5 on: January 08, 2016, 09:43:55 AM »
File moved to dropbox and the original post updated.
 

Offline piercematthew0216

  • Leading Rate
  • *
  • Posts: 6
    • View Profile
Re: v7.10 Patch
« Reply #6 on: January 08, 2016, 07:22:25 PM »
where is the installation directory usually at? I've tried putting the stuff from "Aurora710" into "AuroraUpdate554".     :/
 

Offline Erik Luken

  • Administrator
  • Admiral of the Fleet
  • *****
  • Posts: 5002
  • Thanked: 78 times
    • View Profile
    • Arkayn Game Design
Re: v7.10 Patch
« Reply #7 on: January 08, 2016, 07:40:36 PM »
where is the installation directory usually at? I've tried putting the stuff from "Aurora710" into "AuroraUpdate554".     :/

By default, the installer puts it in Program Files. It is recommended to change that to something else. Once that has finished, unzip the patches to the installed directory.
 

Offline GoldenBoy

  • Able Ordinary Rate
  • Posts: 2
    • View Profile
Re: v7.10 Patch
« Reply #8 on: January 27, 2016, 08:37:32 PM »
I have downloaded the 5.   54 full install.   .    what patches do I need for it to be up too date?

Also could you please add this information to the 5.   54 installation page so that people that are downloading this game now can know how to be up to date?

Thank you in advance

GoldenBoy

Okay so I think I have found the info on the forum and is as follows:
-install 5.  54 base game
-install 7.  00 patch
-install 7.  10 patch
-play game

Am I correct?

Error In LaunchSystemWindow

Error 713 was generated by Aurora
Class not registered.
You need the following file to be installed on your machine.  MSSTDFMT. DLL.
Please report to hxxp: aurora2. pentarch. org/index. php/board,11. 0. html
« Last Edit: January 28, 2016, 12:09:27 AM by GoldenBoy »
 

Offline 83athom

  • Big Ship Commander
  • Vice Admiral
  • **********
  • Posts: 1190
  • Thanked: 79 times
    • View Profile
Re: v7.10 Patch
« Reply #9 on: January 27, 2016, 09:06:48 PM »
By default, the installer puts it in Program Files. It is recommended to change that to something else.
You say that, and I always have in in Program Files (x86) and it never fails on me.
Give a man a fire and he's warm for a day, but set fire to him and he's warm for the rest of his life.
 

Offline Erik Luken

  • Administrator
  • Admiral of the Fleet
  • *****
  • Posts: 5002
  • Thanked: 78 times
    • View Profile
    • Arkayn Game Design
Re: v7.10 Patch
« Reply #10 on: January 28, 2016, 08:21:05 AM »
You say that, and I always have in in Program Files (x86) and it never fails on me.

With Vista and later the UAC doesn't play nice with things being overwritten in Program Files
 

Offline boggo2300

  • Registered
  • Rear Admiral
  • **********
  • Posts: 803
  • Thanked: 9 times
    • View Profile
Re: v7.10 Patch
« Reply #11 on: January 28, 2016, 03:35:50 PM »
have to say,  I've run Aurora from Program Files(x86) in Vista, 7, 8, 8.1 and 10 never with any issues,  on 3 different machines,  so while it's probably a good idea to install elsewhere,  It's not necessarily doom if you don't
The boggosity of the universe tends towards maximum.
 

Offline Mor

  • Commander
  • *********
  • Posts: 305
  • Thanked: 10 times
    • View Profile
Re: v7.10 Patch
« Reply #12 on: January 28, 2016, 06:38:34 PM »
Okay so I think I have found the info on the forum and is as follows:
-install 5.  54 base game
-install 7.  00 patch
-install 7.  10 patch
-play game

Am I correct?

No. When installing the game you need todo 3 steps.
1. Install the game (setup.ext) that comes in 5.54 pack.
2. Extract the update that comes in the 5.54 pack into the install folder.
3. Extract the latest patch. In this case 7.1

You can see this in more detail here:
aurorawiki.pentarch.org/index.php?title=Installation
 
 

Offline GoldenBoy

  • Able Ordinary Rate
  • Posts: 2
    • View Profile
Re: v7.10 Patch
« Reply #13 on: January 28, 2016, 08:57:15 PM »
Got the same error.    I followed all the steps that are in there. 

What do I do with the files labeled: Aurora.  CAB and SETUP.  LST? Do I leave them alone because I did?

I downloaded the   Aurora v7. 1 - All-In-One/Portable release

Thanks AcidWeb  ;D
« Last Edit: January 28, 2016, 10:15:19 PM by GoldenBoy »
 

Offline boggo2300

  • Registered
  • Rear Admiral
  • **********
  • Posts: 803
  • Thanked: 9 times
    • View Profile
Re: v7.10 Patch
« Reply #14 on: January 28, 2016, 09:11:15 PM »
2. Extract the update that comes in the 5.54 pack into the install folder.

this is worded inaccurately,  you need to unzip the update that's in the 5.54 pack into the GAME directory (where you told setup to install it to, I suggest telling setup to use C:\Aurora  and then unzipping the update and 7.01 update into c:\Aurora  (personally I would also unzip those 2 zips in another folder and just copy the files, I've had unexpected results when unzipping into a folder with files of the same name).

@GoldenBoy

the .cab and .lst files are used by setup.exe when you run that for the initial install,  once the game is installed you don't need them anymore (though wait on doing anything with them until you have a working game, you may need them again until then)
« Last Edit: January 28, 2016, 11:02:58 PM by Erik Luken »
The boggosity of the universe tends towards maximum.
 

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51