Author Topic: Windows 7 installation issues  (Read 10354 times)

0 Members and 1 Guest are viewing this topic.

Offline Caleb367

  • Able Ordinary Rate
  • C
  • Posts: 2
Re: Windows 7 installation issues
« Reply #15 on: April 08, 2012, 08:35:16 AM »
Sorry for the thread necromancy, but I have recently upgraded to Windows 7 and had a load of problems getting Aurora to run.  But I made it, so I thought to write this hoping it will help anyone having trouble.

1) Download the AuroraInstall554. zip and the Aurora560. zip from the installation thread (duh).
2) Unpack AuroraInstall554. zip and run Setup. exe.
- You may have the first problem here: I had an error "cannot AutoRedrawImage" or something like this and setup crashed.  If this is the case, follow with the next steps, if not skip to 3:
- This error is caused by the lack of some Visual Basic dll's.
- Therefore, you need to install Microsoft's Visual Studio, latest version - it's free and easy to find by googling it.
- Download the installation file, execute it with the basic options, wait (it's a sizeable download again, about 140 MB)
- You may run into another error regarding VC 9. 0 x86.  It's common enough and a Visual Studio setup bug.
- Look for VC 9. 0 x86 redist on google, download it.
- Run it and either install it from scratch or repair installation-
- Repeat installation of Visual Studio, be warned you'll have to reboot your machine.
- When reboot has completed, try again running Aurora's setup. exe.

3) When choosing a location, DO NOT USE THE PROGRAM FILES PATH.  Windows 7 does not take kindly to system folders being tampered with.  Instead, install to C:\aurora or C:\Games\Aurora.
4) Unpack the AuroraUpdate554. zip patch you got in the AuroraInstall554. zip into your Aurora directory (i. e.  C:\Games\Aurora).  You should have this structure:

5) Unpack your Aurora560. zip into your Aurora directory and overwrite both Aurora. exe and Stevefire. mdb.
- For good measure, install Simple Shutdown Timer, as mentioned in this thread, to get another needed dll.  It may not be necessary, however, I can't say for certain said dll is not installed by Visual Studio.  (You can uninstall it immediately, however)
6) Run Aurora. exe, generate a new galaxy, hit F3 for the System View and immediately skip 5 days.
- You may get an error about syntax: if that's the case, shut down Aurora, head to the Control Panel and change your country settings to English (US).
- you may also want to "Run as Administrator" by right clicking on aurora. exe.
- Important: do not "select" New Game Name or The Space Race, as in those cases half of the windows are completely off-screen and unusable.  Generate a new galaxy from scratch.
7) Play!

Well, that's it, hope it will save someone the hassle, I know I got close to giving up several times, but Aurora's too awesome and kept calling me back like a siren.

Offline sloanjh

  • Global Moderator
  • Admiral of the Fleet
  • *****
  • Posts: 2695
  • Thanked: 47 times
Re: Windows 7 installation issues
« Reply #16 on: April 08, 2012, 10:05:22 AM »
This sounds really nice - could you please cross-post it in FAQ?  You'll probably need to start a new thread....


Offline Maou Tsaou

  • Leading Rate
  • *
  • M
  • Posts: 7
Re: Windows 7 installation issues
« Reply #17 on: April 30, 2012, 02:38:28 PM »
It seems I need to post a few times in order to show I'm not spam (spam,spam,eggs and spam 'as'nt got much spam in it) so I'll report my problems with installation under Window$ 7 64bit pro.
I had poked around on the forums a bit after downloading the install and patch after taking several Win 7 "installation issues" threads as a sign that all may not go well.
As the whole bit seemed to boil down to any one of several possible causes I decided to bite the bullet and just try for an install and see what I was gonna have to deal with.
As I was expecting problems I went with the minimal effort first attempt and just ran setup straight out of the compressed folder.
It asked to overwrite umpteen . dll's with older versions which I refused.
I also put it in C:/Aurora rather than Program Files as Window$ gets spooked about her sys-folders.
So it installed.
"It won't run though" says I.
It runs.
"Here comes the f3 crash" me thinks.
The system map comes up with no problems.
I'm not running as admin and everything seems to be working just fine. . .
I can't help thinking I must have done something wrong.

Now does someone know how to get Civ V to stop bringing up "the blue screen of death"?

Offline Garfunkel

  • Rear Admiral
  • **********
  • Posts: 839
  • Thanked: 46 times
Re: Windows 7 installation issues
« Reply #18 on: May 16, 2012, 05:27:01 PM »
Switch back to Civ IV: Beyond the Sword. Solves all your Civ V problems!  :D

Offline Phobos

  • Able Ordinary Rate
  • Posts: 4
Re: Windows 7 installation issues
« Reply #19 on: February 17, 2013, 09:11:20 AM »
Never mind.  I downloaded and installed a little program called "Simple Shutdown Timer" which has that dll.  hxxp: www. pcwintech. com/simple-shutdown-timer
 Now, F9 works.

This should be put into installation instructions for Windows 7.  It solved my problems.

Offline SenniTreborius

  • Leading Rate
  • *
  • Posts: 13
Re: Windows 7 installation issues
« Reply #20 on: March 21, 2016, 07:53:31 PM »
Simple Shutdown Timer worked for me too.

Offline boggo2300

  • Registered
  • Rear Admiral
  • **********
  • Posts: 830
  • Thanked: 12 times
Re: Windows 7 installation issues
« Reply #21 on: March 28, 2016, 04:17:55 PM »
this thread suddenly sounds like an infomercial...
The boggosity of the universe tends towards maximum.


Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52