Author Topic: Working around the ship build rate bug  (Read 1000 times)

0 Members and 1 Guest are viewing this topic.

Offline Black Rabbit

  • Petty Officer
  • **
  • Posts: 26
Working around the ship build rate bug
« on: September 22, 2011, 02:03:47 PM »
Alright.  So the latest version, what, halves the ship build rate, right?  (Or does it decrease it more than that?)

Assuming it's just half, would an effective workaround be to just double all racial build rates for the game being played in the database until a patch comes out?  (To obtain the intended/designed buld rate.)
 

Offline Ashery

  • Warrant Officer, Class 1
  • *****
  • A
  • Posts: 91
Re: Working around the ship build rate bug
« Reply #1 on: September 22, 2011, 02:12:19 PM »
The problem is a bit more complex.

First of all, it only affects commercial shipyards, so a simple doubling of the racial build speed won't be a balanced fix.

More importantly, though, is that it doesn't simply halve the expected ABR. Instead, the bug involves the game taking the size of every commercial vessel to be 0 tons when determining the effective build rate. With the way the effective build rate is calculated, this results in an effective build rate that will always be at half your racial. It doesn't matter if you're building a 1000ton or a 100,000ton vessel.
 

Offline Thiosk

  • Commodore
  • **********
  • Posts: 784
  • Thanked: 1 times
Re: Working around the ship build rate bug
« Reply #2 on: September 22, 2011, 03:35:26 PM »
yeah, i've noticed this and its been a little annoying-- I got around it by simply prefabbing the engines and other key components (terraformers, jump gate construction modules).  This brings the wait time down a bit, but its still a bit out of control.
 

Offline Black Rabbit

  • Petty Officer
  • **
  • Posts: 26
Re: Working around the ship build rate bug
« Reply #3 on: September 22, 2011, 03:41:06 PM »
Ah well.  I guess that means being limited pretty much to prefabbing for a decent workaround.
 

Offline Steve Walmsley

  • Aurora Designer
  • Admiral of the Fleet
  • S
  • Posts: 7192
  • Thanked: 2240 times
    • http://www.starfireassistant.com
Re: Working around the ship build rate bug
« Reply #4 on: September 22, 2011, 03:43:39 PM »
Alright.  So the latest version, what, halves the ship build rate, right?  (Or does it decrease it more than that?)

Assuming it's just half, would an effective workaround be to just double all racial build rates for the game being played in the database until a patch comes out?  (To obtain the intended/designed buld rate.)


I haven't looked at normal Aurora for a couple of weeks. Is this just affecting production times or does it also show up in the shipyard display tab?

Steve
 

Offline Ashery

  • Warrant Officer, Class 1
  • *****
  • A
  • Posts: 91
Re: Working around the ship build rate bug
« Reply #5 on: September 22, 2011, 03:49:30 PM »
I haven't looked at normal Aurora for a couple of weeks. Is this just affecting production times or does it also show up in the shipyard display tab?

Steve

Under "Manage Shipyards" the mod rate is correct, but under "Shipyard Tasks" the ABR is always half of the modified (admin bonuses) racial.
 

Offline Steve Walmsley

  • Aurora Designer
  • Admiral of the Fleet
  • S
  • Posts: 7192
  • Thanked: 2240 times
    • http://www.starfireassistant.com
Re: Working around the ship build rate bug
« Reply #6 on: September 23, 2011, 01:28:36 PM »
Under "Manage Shipyards" the mod rate is correct, but under "Shipyard Tasks" the ABR is always half of the modified (admin bonuses) racial.

Thanks. I have found and fixed it. I'll release a v5.53 with this fix later tonight

Steve
 

Offline Napoleon XIX

  • Petty Officer
  • **
  • N
  • Posts: 26
Re: Working around the ship build rate bug
« Reply #7 on: September 23, 2011, 03:07:50 PM »
Thanks. I have found and fixed it. I'll release a v5.53 with this fix later tonight

Steve

Will this be compatible with 5.52 saves?
 

Offline Dutchling

  • Lieutenant
  • *******
  • Posts: 173
  • Baby Snatcher!
Re: Working around the ship build rate bug
« Reply #8 on: September 23, 2011, 04:30:00 PM »
Will this be compatible with 5.52 saves?
Yes it is
 

Offline Black Rabbit

  • Petty Officer
  • **
  • Posts: 26
Re: Working around the ship build rate bug
« Reply #9 on: September 23, 2011, 08:09:13 PM »
Woohoo!  Thanks for the quickfix, Steve!
 

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54