Author Topic: Error 339 was generated by Aurora  (Read 1936 times)

0 Members and 1 Guest are viewing this topic.

Offline Merlin4711

  • Able Ordinary Rate
  • M
  • Posts: 3
Error 339 was generated by Aurora
« on: December 05, 2013, 03:06:01 PM »

Well.  .  .   right now this is the reason I registered myself to that community :) But.  .  .   I noticed that there is a huge area filled with fan fiction (and stuff), so don't expect get rid of me verry soon ;)


Whats wrong?

Opening the game and hitting F9 in the.  .  .   menu-only-bar-part of the game (where it name the games title, the date and your empire) create an error. 
Well, there are many other Error-Messages at all, but this one make it impossible for me to create a custom race start as described in the wiki.   

What happens?

Well.  .  .   I could make a screenshot of that errormessage, but I'm too lazy to upload it ;)
ehm.  .  .   it says this:

Error in LaunchSystemWindow

Error  339 was generated by Aurora
Component 'COMCTL32.  OCX' or one of its dependencies not correctly registered:
a file is missing or invalid
Please report to hxxp: auroa2 and so on

Well, here I am.   :D

What did I do?

I took the v5 Maininstallation, pasted the two patches to get v6.  21.   All of this was placed far away from anything Windows would take care about.   
Speaking about Windows - its Windows 7 Pro 64
Before this, I installed the installer-package, which is responsible for placing all the system-files somewhere they should be of use.   I kept the newer files the installer named, as described in the wiki. 
Unfortunally, it says that the file that cause some trouble to me is already existent.   Anyway, if I search the Windows/system32/ folder for it.  .  .   nothing is there.   
But, after let Windows perform a full scale search at the system-partition the missing file was sighted somewhere like Windows/SysWOW64.   Verry well. 
I tried to copypaste it into system32, but.  .  .   that didn't help. 

After this I asked google for help.   And the search-function of this forum.   Second one just referred to a single-post-fred, that wasn't useful at all. 
Google led me to serval windows-communities, or programs that use this file too.   And encounter the same problems.   Their solution of choice was reregistering that file.   After unregistering it at first place.   
some CMD-command (run as admin).  .  .   uh.  .  .   regsvr32 or something like this.   Trying this without the file availabe in system32 just create an error.   Try this with the file copypasted over, get me an "may not be compatilbe"-blabla.   
Changing CMDs shown path to that SysWOW64 and using that command again, provide a was-sucessful-message.   A.  .  .   a light at the hyperjumps end?
No.   Same error.   

That was the point I really got pissed of.   All good games seems to refuse to work at my PC.   Dwarf Fortress was pain in the ass to get running properly too.   And now.  .  .   Aurora. 

Okay.   Next thing I tried.   Some absolute-low-level-skills of PC-beating send some kind of memory-flash trough my head.   
Oh, say it simple: I remember about a place, somewhere inside windows, where you can define a standard-path for about.  .  .   everything.   Hard thing was to find it again in Windows 7.   Did I mention that I fuc*ing hate that new system-settings layout? No? Well.   
 :-X :-X :-X :-X :-X :-X

So.   that had to be said.   
Where was I? Ahh.  .  .   after finding the envoironmental variables place again, I added a entrace for COMCTL32.  OCX. 
Needless to say, that didn't help. 

Last thing I hope it could help was the portable installation of Aurora.   At the very end, there is that damned file available just in the same directory! This MUST work.   
Wel.  .  .   It didn't.   Same Error as every year, Miss Sophie.   

Now I reached the point i will beg for help.   

Just for the protocol: I did reinstall all of that stuff over and over again.   I even permitted the installation of all older files that are not a .  dll.   Most annoying about this: They won't show up in the system32 directory after this.   And yes, the installer was granted with admin-rights.   

So.  .  .   anything I miss here?

EDIT: Ah, I forgot to say that I installed that simple shutdown timer (and deinstalled it) too.  Didn't chance anything.
« Last Edit: December 05, 2013, 03:36:22 PM by Merlin4711 »

Offline Erik Luken

  • Administrator
  • Admiral of the Fleet
  • *****
  • Posts: 5159
  • Thanked: 117 times
  • Discord Username: icehawke
Re: Error 339 was generated by Aurora
« Reply #1 on: December 05, 2013, 04:21:43 PM »

Offline Merlin4711

  • Able Ordinary Rate
  • M
  • Posts: 3
Re: Error 339 was generated by Aurora
« Reply #2 on: December 05, 2013, 04:42:43 PM »
Wuuuuh, a Reply this fast.

But. . .  unfortunally I tried out the Mobile Versions too (as described somewhere in my first post).  Well, I didn'T use the beta-variant last time.  But this time.  And it still provide the same Error.

Even more frustrating: I remember that I installed it completely  wrong the first time, with many Error appearing just because half of the needed files weren't available to the game.  But back than, that piece of great software didn't provide the error I opened this fred for.

It just appeared after the first step-by-step installation guided by the Wiki, when trying to get a Custom Race. 
And now it won't go away. 

Offline Merlin4711

  • Able Ordinary Rate
  • M
  • Posts: 3
Re: Error 339 was generated by Aurora
« Reply #3 on: December 06, 2013, 07:19:23 AM »
Hallo again!

I know, a double-post isn't a the fine art of forum-trolling.  .  .   ehm.  .  .   I mean, it is.  .  .   anyway;

I thing I solved that problem.   By surprise.   

This day, I looked for some old stuff at my System-Drive I could kick off the Harddisk to free up some space.   Short story - there were a couple of Aurora-Installations that weren't named "Aurora" or something, they had a # followed by a number and managed to hide from my work yesterday successful.   

I kicked these off my PC.   Than I thought "Well, new day, new hope" and installed Aurora one more time.   Getting errors as well.   But .  .  .   at least the Error was another one.   
Than I tried something I stumpeld upon yesterday night. 

Thats what I did

After realizing that the files Aurora didn't find are at C:/windows/syswow64/, I opened a CMD with admin permissions, made it open that path and than use the command I tried out yesterday. 
But this time, a new part did come in handy: unregistering that damn file at the first place. 

so I entered regsvr32 /u StupidFileThatsNamedInTheErrorMessage.  ocx
Got a success-message
Next step was entering regsvr32 StupidFileThatsNamedInTheErrorMessage.  ocx
Got another success-message

Without too much hope left, I started Aurora one more time (using the installation, not the mobile version).   An guess what? I got another error-message.   But with another file this time.   A DLL in that case. 
I wonder what would happen, if.  .  . 

Well, after unregister and reregister all files that appeared in the errormessages, the game seems to work! Well, until now at least.   But.  .  .   YAAY!  ;D

I have to take care of the Decimal-Separator Thing (well, this User does come from Germany where I have to take care about this) and I know I will forget this serval times (and crush that game), but.  .  .   YAY  :D

So.   I don't know, but maybe this will help other people which may encounter that problem too?

So go away, I going to build some 60. 000t Battleships (after reading serval Forum-Posts I wonder that military ships are as light as WWII Day Destroyers! I plan to try some stupid stuff)
« Last Edit: December 06, 2013, 07:24:32 AM by Merlin4711 »

Offline GeaXle

  • Chief Petty Officer
  • ***
  • G
  • Posts: 44
  • Thanked: 3 times
Re: Error 339 was generated by Aurora
« Reply #4 on: March 24, 2014, 09:06:56 AM »
Thank you great sir!

Offline whaleberg

  • Able Ordinary Rate
  • w
  • Posts: 1
Re: Error 339 was generated by Aurora
« Reply #5 on: April 15, 2014, 10:21:59 PM »
Thank you for this post!  You saved me hours of frustration and wasted time.

Offline evanator66

  • Able Ordinary Rate
  • e
  • Posts: 1
Re: Error 339 was generated by Aurora
« Reply #6 on: January 15, 2015, 07:08:52 PM »
Thank you so much!!!
I was getting very frustrated, and you just saved me hours of hair tearing!

Offline MarcAFK

  • Vice Admiral
  • **********
  • Posts: 1787
  • Thanked: 71 times
  •'s so simple an idiot could have devised it..
Re: Error 339 was generated by Aurora
« Reply #7 on: January 15, 2015, 10:32:55 PM »
This is new to me, But congrats and welcome to the club!
" Why is this godforsaken hellhole worth dying for? "
". . .  We know nothing about them, their language, their history or what they look like.  But we can assume this.  They stand for everything we don't stand for.  Also they told me you guys look like dorks. "
"Stop exploding, you cowards.  "


Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54