Author Topic: Bug reports  (Read 7573 times)

0 Members and 1 Guest are viewing this topic.

Offline Triato

  • Warrant Officer, Class 1
  • *****
  • T
  • Posts: 75
  • Thanked: 4 times
Re: Bugs report
« Reply #135 on: April 14, 2020, 12:46:31 PM »
I am setting up a game where a single small faction on earth is given some ships and tech by aliens. I wanted the initial ships to be relativelly hi tech but the earth faction to start low tech. So I created an alien empire with SM and tried to transfer the fleets to the Earth faction. Game crashed when I pressed the transfer bottton.

I plan to give the Earth faction boarding capacity for them to get the ships, so its not much problem for my game, but may be for other games where we may want to frequently transfer fleets.. I did a search for transfer and didn´t find the bug reported.
 

Offline Triato

  • Warrant Officer, Class 1
  • *****
  • T
  • Posts: 75
  • Thanked: 4 times
Re: Bugs report
« Reply #136 on: April 14, 2020, 10:48:37 PM »
And that lead to another bug found. After giving the order to board a ship, my troops just disapeared and there were no boarding action messages.
 

Offline Kyle

  • Moderator
  • Lt. Commander
  • *****
  • K
  • Posts: 260
  • Thanked: 617 times
  • Quasar4x dev
Re: Bugs report
« Reply #137 on: April 15, 2020, 12:53:24 PM »
Hello,

Account pending approval, but wanted to submit a potential bug for Quasar.
Win 10/64-bit.

This has occurred both in V103 and V105 according to the game.

- Created a new game, only changes being to the name of the empire and changing the empire theme to "Nations of Earth".
- Issue arises where a created research project (for ion engines) will not advance; the RP needed does not decrease and the estimated completion date extends out 5 days at each 5-day increment.
- Once this happens, the scientist that was assigned to it will not progress ANY research project assigned to them (created or normal).
- The issue might be related to attempting to queue a project along with the engine project.
- The issue is not resolved by cancelling the project, or deleting the racial tech and recreating it.
- With V105, I had deleted the previous version and fresh-unzipped the downloaded V105, starting fresh.

I couldn't reproduce this. Can you post the save file?


I am setting up a game where a single small faction on earth is given some ships and tech by aliens. I wanted the initial ships to be relativelly hi tech but the earth faction to start low tech. So I created an alien empire with SM and tried to transfer the fleets to the Earth faction. Game crashed when I pressed the transfer bottton.

I plan to give the Earth faction boarding capacity for them to get the ships, so its not much problem for my game, but may be for other games where we may want to frequently transfer fleets.. I did a search for transfer and didn´t find the bug reported.
And that lead to another bug found. After giving the order to board a ship, my troops just disapeared and there were no boarding action messages.

To save me some time setting all of this up in a test scenario, can you post a save file for these issues?
 

Offline Triato

  • Warrant Officer, Class 1
  • *****
  • T
  • Posts: 75
  • Thanked: 4 times
Re: Bug reports
« Reply #138 on: April 16, 2020, 08:49:15 AM »
Sorry, I have changed a lot of the game since the bug. Ill be very busy the next few days, but Ill try to replicate the bug on the weekend if it still usefull.

 

Offline Agm-114

  • Pulsar 4x Dev
  • Registered
  • Chief Petty Officer
  • ***
  • Posts: 32
  • Thanked: 12 times
  • Discord Username: AGM-114#7218
Re: Bug reports
« Reply #139 on: April 19, 2020, 11:30:18 AM »
So, not an issue I've been able to verify myself since I am away from my main pc but God of Exp on the discord would like to share.
According to him tech only research 1 at a time.
 

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72