Author Topic: Official v6.10 Bugs Thread  (Read 17767 times)

0 Members and 1 Guest are viewing this topic.

Offline Steve Walmsley

  • Aurora Designer
  • Admiral of the Fleet
  • S
  • Posts: 6871
  • Thanked: 1502 times
    • http://www.starfireassistant.com
Official v6.10 Bugs Thread
« on: October 21, 2012, 12:41:11 PM »
Please post confirmed bugs for v6.10 in this thread. However, please read the guidelines below on reporting bugs before posting. If you had a bug in v6.00 and it still isn't fixed, please report it again in this thread.

Bug Reporting Guidelines

Steve
« Last Edit: November 25, 2012, 07:45:01 PM by Steve Walmsley »
 

Offline tryrar

  • Sub-Lieutenant
  • ******
  • t
  • Posts: 100
Re: Official v6.10 Bugs Thread
« Reply #1 on: October 21, 2012, 01:24:35 PM »
First one off the bat  :P

Got a 3061 error in check for missiles "too few parameters. Expected 1" followed by an error 91 "object variable or with block variable not set". Since I haven't designed missiles yet, I'm guessing its an NPR problem
 

Offline Bouchart

  • Petty Officer
  • **
  • B
  • Posts: 23
Re: Official v6.10 Bugs Thread
« Reply #2 on: October 21, 2012, 01:28:40 PM »
Yes I have the same problem.

Also, research points and construction points don't seem to accumulate over time.
 

Offline Victuz

  • Warrant Officer, Class 1
  • *****
  • Posts: 80
Re: Official v6.10 Bugs Thread
« Reply #3 on: October 21, 2012, 02:39:21 PM »
After updating to 6.10 I get error 3061 followed by error 91 same as the rest.

I have changed my separator to a dot than to a coma than to dot again to make sure. It still happens.

I have played with 6.00 an hour earlier and it seemed to work fine.
« Last Edit: October 21, 2012, 02:41:02 PM by Victuz »
 

Offline Steve Walmsley

  • Aurora Designer
  • Admiral of the Fleet
  • S
  • Posts: 6871
  • Thanked: 1502 times
    • http://www.starfireassistant.com
Re: Official v6.10 Bugs Thread
« Reply #4 on: October 21, 2012, 03:26:33 PM »
First one off the bat  :P

Got a 3061 error in check for missiles "too few parameters. Expected 1" followed by an error 91 "object variable or with block variable not set". Since I haven't designed missiles yet, I'm guessing its an NPR problem

Fixed it - rather than create a brand new version I have updated the Aurora.exe in the v6.10 patch file. If you have already set up a v6.10 campaign you can download the patch again and only update the Aurora.exe.

Steve
« Last Edit: October 21, 2012, 03:28:48 PM by Steve Walmsley »
 

Offline byron

  • Rear Admiral
  • **********
  • b
  • Posts: 883
  • Thanked: 28 times
Re: Official v6.10 Bugs Thread
« Reply #5 on: October 21, 2012, 05:43:23 PM »
I tried an SM game, and got an Error 381 followed by Error 11s when I tried to generate a random system.  This happened twice, so it wasn't the specific system generated.
This is Excel-in-Space, not Wing Commander - Rastaman
 

Offline metalax

  • Commander
  • *********
  • m
  • Posts: 355
  • Thanked: 4 times
Re: Official v6.10 Bugs Thread
« Reply #6 on: October 21, 2012, 06:04:17 PM »
Minor one: Conventional start, going to design a conventional engine and the name that appears for the engine is simply "1 EP ", not "1 EP Conventional Engine". Same occurs if you go back to conventional engine tech from a TN start.

Also very minor consistancy issue, in research and on the drop down when designing engines it is "Ion Engine Technology", but "Ion Drive" when naming the designed engine as opposed to "Magneto-plasma Drive Technology" with "Magneto-plasma Drive".

Edit:
Size 50, power x1 engine should be military and are listed as such in the component design screen. However if added to a ship in the class design screen they do not change the class to military, it remains commercial unless another part that would change it to military is added.
Only tested with conventional engine so far.
« Last Edit: October 21, 2012, 06:22:11 PM by metalax »
 

Offline Brian

  • Vice Admiral
  • **********
  • Posts: 1212
  • Thanked: 1 times
Re: Official v6.10 Bugs Thread
« Reply #7 on: October 21, 2012, 08:26:47 PM »
I tried an SM game, and got an Error 381 followed by Error 11s when I tried to generate a random system.  This happened twice, so it wasn't the specific system generated.
I got the same problem.  I then went into the crusade scenario and had no problem at all in creating new systems.  It created them quickly as well.  When I tried to create a nebula system it gave me the expected answer of being turned off in a real stars game.

Edit 1.  I started a new game using a Sol start, real stars turned off.  I then tried to create systems through the F9 screen.  Every time I created a system it was given the same name (Ross 154).  They all had different system ID numbers.  This continued when I tried using the enter/explore button on the jump point tab.  It created new systems, but they still had the same name.  Both regular systems and nebula systems were created this way.
 
Brian
« Last Edit: October 21, 2012, 08:39:15 PM by Brian »
 

Offline metalax

  • Commander
  • *********
  • m
  • Posts: 355
  • Thanked: 4 times
Re: Official v6.10 Bugs Thread
« Reply #8 on: October 22, 2012, 05:25:50 AM »
Not entirely sure if this is a bug.

In a new game from a conventional start, and I have not yet started to conduct geosurveys. One of the civilian lines builds a fuel harvester which then heads off to an apparent deposit on unsurveyed Saturn. I was under the impression that minerals on a body were only generated when the body was surveyed, has that now changed? Will it be consuming minerals from a dpeosit that will be revealed when surveyed or is it pulling them out of the ether?

edit:

On the technology report screen, EM Sensors are unable to be renamed. The rename box comes up when selected but it does not save whatever is typed in, it keeps the original name.
« Last Edit: October 22, 2012, 06:01:23 AM by metalax »
 

Offline rymwoo

  • Able Ordinary Rate
  • r
  • Posts: 2
Re: Official v6.10 Bugs Thread
« Reply #9 on: October 22, 2012, 01:35:30 PM »
The Range(km) column of Fuel Report / Fuel Situation has some pretty large (and wrong) values
 

Offline Rabid_Cog

  • Lt. Commander
  • ********
  • Posts: 237
  • Thanked: 5 times
Re: Official v6.10 Bugs Thread
« Reply #10 on: October 22, 2012, 01:51:16 PM »
I tried to go with SM race but I can't enter the F9 window (and hence create new systems). It throws some kind of array out of bounds error.

So I tried to work around that and create a Sol system first, but now it gives a new problem.

Error in Launch System Window
Error 713 was generated by Aurora
Class not registered.
You need the following file to be installed on your machine. MSSTDFMT.DLL

This computer was recently formatted, but I ran the Aurora 5.54 installer with the setup and cab file that installs all the DLLs and everything before updating to 6.1.
I did, however, say to keep my own file if it told me I have a newer version.

Edit: Duuuuuh, should learn to read forums. First point holds though.
« Last Edit: October 22, 2012, 02:03:49 PM by Rabid_Cog »
I have my own subforum now!
Shameless plug for my own Aurora story game:
5.6 part: http://aurora2.pentarch.org/index.php/topic,4988.0.html
6.2 part: http://aurora2.pentarch.org/index.php/topic,5906.0.html

Feel free to post comments!
http://aurora2.pentarch.org/index.php/topic,5452.0.html
 

Offline Rabid_Cog

  • Lt. Commander
  • ********
  • Posts: 237
  • Thanked: 5 times
Re: Official v6.10 Bugs Thread
« Reply #11 on: October 22, 2012, 02:14:48 PM »
Here is the full bug details. I've done this in 6.00 as well so I assume it is the same bug.

Message:

Error in cboSystems
Error 381 was generated by Aurora
Invalid property array index
Please report... etc.

Followed by:

Error in GetBodySuitability
Error 11 was generated by Aurora
Division by zero
Please report... etc.

After which Aurora crashes.

To reproduce, simply start a new game with SM race. Select SM race as your default and press F9 (possibly generating the Sol system first). It is not the NPRs as I set the starting number to 0 (as well as untick that little box that says generate 1 or more).
I have my own subforum now!
Shameless plug for my own Aurora story game:
5.6 part: http://aurora2.pentarch.org/index.php/topic,4988.0.html
6.2 part: http://aurora2.pentarch.org/index.php/topic,5906.0.html

Feel free to post comments!
http://aurora2.pentarch.org/index.php/topic,5452.0.html
 

Offline ardem

  • Commodore
  • **********
  • a
  • Posts: 771
  • Thanked: 13 times
Re: Official v6.10 Bugs Thread
« Reply #12 on: October 22, 2012, 06:20:57 PM »
Not entirely sure if this is a bug.

In a new game from a conventional start, and I have not yet started to conduct geosurveys. One of the civilian lines builds a fuel harvester which then heads off to an apparent deposit on unsurveyed Saturn. I was under the impression that minerals on a body were only generated when the body was surveyed, has that now changed? Will it be consuming minerals from a dpeosit that will be revealed when surveyed or is it pulling them out of the ether?


I love this if this is not a bug, That means the corporate have there own survey ships and not sharing the information with the Government.
 

Offline Sloshmonger

  • Warrant Officer, Class 1
  • *****
  • S
  • Posts: 79
Re: Official v6.10 Bugs Thread
« Reply #13 on: October 22, 2012, 06:31:55 PM »
1) Me Too on the F9 system error 381/error 11.

2) I don't know if this is a "bug" or an unforeseen consequence of civilian design..

I generated a new game with a race whose capital is in a level 4 nebula (625 km/s per armor layer).

My civilians are running around, every single ship, at 625 km/s, so I take it they're not adding any additional armor to their designs.  I never got them to go outside the nebula (v6.10 showed up), so don't know what their true speed was.
 

Offline TheBeardyMan

  • Leading Rate
  • *
  • T
  • Posts: 6
Re: Official v6.10 Bugs Thread
« Reply #14 on: October 22, 2012, 06:48:02 PM »
Flags only go up to flag0389. jpg, but opening the galactic map in "Crusade" requires flag0391. jpg.
 

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52